2016.06

Systemanforderungen

MyCoRe ist eine betriebssystemunabhängige Java-Anwendung und bringt bereits viele Komponenten mit. Einige Voraussetzungen sind jedoch zu schaffen, bevor Sie eine MyCoRe-Anwendung installieren oder an MyCoRe mitentwickeln können.

Für den Betrieb einer MyCoRe-Anwendung

  • JRE 1.8
  • Tomcat v8 oder höher (bzw. ServletContainer mit Servlet-3.1-Unterstützung)
  • Apache Solr 4.10
  • relationales Datenbanksystem (hibernatefähig)

Für die MyCoRe-(Anwendungs)-Entwicklung

Neben den oben genannten Komponenten benötigen Sie für die Entwicklung mit MyCoRe weiterhin:

  • JDK 1.8
  • Maven 3 oder höher
  • SVN 1.8 oder höher

Installation

Solr-Installation

Für die Suchfunktionalität von MyCoRe wird ein Solr-Server vorausgesetzt. Informationen zur Installation speziell für MyCoRe sind in der entsprechenden Solr-Dokumentation zu finden. Umfassende Informationen zur Solr-Installation und Konfiguration finden sich in der Solr-Dokumentation von Apache.

Relationales Datenbanksystem

MIR und Skeleton zeigen, wie H2 als im-Speicher-laufendes relationales Datenbanksystem (In-Memory-Datenbank) genutzt werden kann. In diesem Fall muss kein relationales Datenbanksystem bereitgestellt werden. Für den Produktivbetrieb empfehlen wir jedoch die Verwendung eines herkömmlichen Datenbankmanagementsystems, dass nicht den Arbeitsspeicher als Datenspeicher nutzt..

Die Anbindung der Datenbank erfolgt über JPA und Hibernate, daher muss eine entsprechende Hibernate-Unterstützung verfügbar sein. Prüfen Sie also bitte vor der Wahl Ihres Systems, ob diese vorliegt. Nutzen Sie dazu die Dialekt-Übersicht.

 Kathleen Neumann - 2016-07-19